Jump to content
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Sign in to follow this  
Hoppah

Who is able to fix this bug for me?

Recommended Posts

Hi, :cry:

As some of you know you cannot unload the boat from the LAFD Motorboat Transporter in mission 7 (Police chase ends in tragedy). I've been trying to fix this bug for ages and have not been able to fix it. It's driving me nuts. The one who can fix this might get a test version of the Los Angeles Mod v2.0. I can't promise anything though, but I'll see what I can do.

The bug is that the LAFD Motorboat Transporter does not wants to unload its motorboat at the landing stage.

It drives to the indicated loading point (also called a 'TFMB landing stage' in the editor) and just sits there. Screenshot:

mission7.th.jpg

The bug is not related to scripts or the LAFD Motorboat Transporter as it works fine in other missions. It's definately the map file which is causing the problem. I've already made a few changes to the map myself. I tried to move virtual objects, change the terrain height, change the landing stage itself, but nothing seems to work. You can find the map of mission 7 with my changes in the attached .rar file. It might be useful if you want to give it a shot. In case you are not familiar with the TFMB landing stages, you can find the stage under 'Waiting points' in the editor. :)

Hoppah

Share this post


Link to post
Share on other sites
Guest em4fan

Last night I played this mission and no problem with putting the boat in the water

em4fan

Share this post


Link to post
Share on other sites

I remember being able to put it in the water a while ago. I have just tried now but it doesn't work. Maybe something to do with patch edits?

Share this post


Link to post
Share on other sites
Don't you think he (or anyone else) would of tried that?

it's possible, but for em4fun it works.

Share this post


Link to post
Share on other sites
it's possible, but for em4fun it works.

Doesn't mean it's not bugged. It's ok to post suggestions, but don't you think restarting the game is something I didn't already try while testing my own changes to the map?

Em4fun might confuse this mission with the other mission ("Motorway bridge collapses!") which plays on the same map. The LAFD Boat Transporter works fine on that one. For the LA Mod mission I moved the loading stage point to a different location and something went wrong there. None of the patches for LA Mod v1.9 change something to that map, the boat transporter or its commands.

Hoppah

Share this post


Link to post
Share on other sites
Doesn't mean it's not bugged. It's ok to post suggestions, but don't you think restarting the game is something I didn't already try while testing my own changes to the map?

Em4fun might confuse this mission with the other mission ("Motorway bridge collapses!") which plays on the same map. The LAFD Boat Transporter works fine on that one. For the LA Mod mission I moved the loading stage point to a different location and something went wrong there. None of the patches for LA Mod v1.9 change something to that map, the boat transporter or its commands.

Hoppah

I'm going to try if it works to me

EDIT: It doesn'T work for me too and I try to fix it but failed. I don't know how to fix this

Share this post


Link to post
Share on other sites

I will take a look and see if i cant come up with something. Slightly off topic but ever have any luck fixing the hostage situations using one of my two suggestions?

Share this post


Link to post
Share on other sites
I will take a look and see if i cant come up with something. Slightly off topic but ever have any luck fixing the hostage situations using one of my two suggestions?

When and where did you post these suggestions? I can't remember if I have read them.

Share this post


Link to post
Share on other sites

lol some where ib the bug report topic i think, and i made a topic in the LA Mod forum to. Off the top of my head, I noticed one key difference between the Deluxe map hostage events and the hostage events on the new map. On the old map the houses, like the one across from FS1, was empty aside from one guy I believe. The house had a name set for it on the properties menu for the specific house(forget the exact name the editor uses, child maybe). Then when the event happens the game spawns the people automatically.

The original thing I noticed was if you placed a person on the map, selected the person on the map, hit properties, hit edit child I believe, and theres an option to set people as a hostage. I havent tried it personally. I have just been lazy.

Off topic again, but maybe you could enlighten me on something, how do you make a suicide jumper in a window? I checked the old map where I had a jumper before but there seemed to be nothing to trigger the event in that location. Is it randomly generated like medical runs?

Share this post


Link to post
Share on other sites

The buildings with the hostage events have the name 'hostages', the person(s) inside the house are named 'house_person', but lets stick to the topic now.

Big edit:

Before people ask, the new SWR truck and boat have the same problem on that map.

Share this post


Link to post
Share on other sites

Hmm, I think I am going to give it a try.

Not sure if my idea is going to work, but ill see.

Share this post


Link to post
Share on other sites
Try to take an another place on the map?

Not an option, the stage point should be there, or at least on that part of the shore. Why don't you try to fix it yourself? That's actually the reason I made this topic, to let people know I might need some help to fix the problem.

Share this post


Link to post
Share on other sites
The buildings with the hostage events have the name 'hostages', the person(s) inside the house are named 'house_person', but lets stick to the topic now.

Big edit:

Before people ask, the new SWR truck and boat have the same problem on that map.

I never said anything about naming people. I'll try to look at it later and report it in the bug topic.

So still no idea?

Whats it look like?

Share this post


Link to post
Share on other sites

Have you checked the unit.xml file for the boat?

The line "missions value" should contain any mission in which you want to use the boat.

Regards

Woltep

Share this post


Link to post
Share on other sites
Have you checked the unit.xml file for the boat?

The line "missions value" should contain any mission in which you want to use the boat.

Regards

Woltep

Jackpot! :12:

The indexnumber of LA Mod mission 7 is 32, which had to be added to the unit.xml file of original FMB (Los Angeles Mod v1.9/Units/Vehicles/Fire Department/070FMB/unit.xml) too. For some reason the unit ID of the motorboat is hardcoded to "FMB", that's why a change to that file is required to make it work in these missions. I just totally forgot about that. :1046275767_ugly:

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...