Jump to content
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Sign in to follow this  
William Stapleford

Help adding new texture and prefab to the Em5 editor

Recommended Posts

This is cross posted on another forum

----------------------------------------------------------------------------

If this has been covered or shows as a duplicate I apologize, I wrote something like this last night and the forum went down and the post appeared to be lost.
 
I have been working with a guy named "Walker" via email and have run into a complete stop and can no longer make any positive progress.  The idea was to add an object to the Em5 game as a NEW prefab.  Here is the basic setup and the steps I have taken thus far.
I'm using 3dsmax 2015 and the OGRE export built into the toolbar of the program it was a separate download.  I'm using the US Steam version of EM5 patched to version 1.4.1
 
I created a new object in the 3dsmax 2015 program.  It was made with several objects that were all properly attached using the program.  I also created a new object texture using Paint Shop pro 8.  This texture was 4096X4096 and was saved in this format.
"objectname_c.tif"  I did not create a greyscale colormap of this object as of yet.
I used the material editor in the 3dsmax program to attach the texture to the object.  I confirmed the texture in the 3d Render preview of the object.  
 
I then created a folder for the export for this object.  This project folder was called "objectname_export"
 
Using the OGREMAX toolbar found on the 3dsmax2015 I exported the project as .scene file to this folder.  When the export was done it created the following files.
 
"objectname.scene"
"objectname.mesh"
"objectname.material"
 
There were no subfolders and the texture file was never placed in the folder.  This is where Walker and I are getting different results.  He says that when he exports he will get a subfolders and additional files that I never see.  I'm not sure why and maybe that is the whole problem.
I manually browse to and copy the texture file "objectname_c.tif" file into the "objectname_export" folder.
 
Then I take all the files listed above MINUS the "objectname.scene" file and drag them into another folder named "objectname"  This gives me a total of 3 files that are in this folder.  (.mesh .material .tif )
 
I then open Em5 and go into the EM5 world editor.  I use f11 to create a new project and name it "objectname"
I minimize the Em5 world editor (resize) and drag and drop the "objectname.mesh" file into the Em5 editor window.  When the file is dropped it creates the correct file and I save them.
 
When I go to the new "objectname" prefab and drag it into the editor window it shows the object but it is all white with no textures applied to it at all.
In the DEBUG window there is an error that shows in RED text ...
 
"[QSF error] Can't assign material 1003411756 to SubEntity of because this Material does not exist. Have you forgotten to define it in a .material script?"
 
At this point I'm lost as it appears that everything went correctly and was placed correctly.  I know I saw that the editor imported the .material file.
I also even added the "SVN" folder to the Em5 "objectname" project folder.
 
In a fit of desperation I too the "objectname_c.tif" texture into the project folder and added the correct folders for it to sit in.   I created the "texture" and the "_derived" folders and placed the "objectname_c.tif" into that folder.
 
Still had the same results and same error.
 
I have deleted the project and verified all the files for the old project were removed and tried again.  Still no results that would make me happy.
 
This is where I'm hoping that someone can help me.  I have tried to understand the tutorial videos and have been doing everything that I can think of correctly but I'm sure I probably missed something,
 
I'm now over frustrated and about to just give up on this whole thing.  The lack of support from the developer is a joke and pisses me off even more.
 
Please if you can offer any help to make this work I can finally start getting some better and more complex items into the game.
 
Thanks and have a great day
 
William516
Bill
Delaware, USA

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...