Jump to content
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
  • Announcements

    • randomperson139

      Signatures   03/04/2016

      Hi everyone. It appears that the update to the new forum has affected the format of the majority of signatures (adding extra spaces, changing sizes etc.). Due to this, could everyone please check their own signature, ensuring that it complies with the site rules. See the http://www.emergency-planet.com/tos.html/ or http://www.emergency-planet.com/topic/16848-acceptable-signature-sizes/ for more information.  We'll give it a few weeks to give enough time to edit signatures, after that the unnecessarily large signatures will simply be removed. Thanks for your cooperation. Regards, EMP Staff.
MedicalByte

Blender V3O Import/Export Scripts

Recommended Posts

58 minutes ago, mr matt5432123 said:

The download link isn't fixed (yet) at least for me, is it working for you?

No, I don't have it. I think it was originally an attachment to the website and it probably got broken after the website update. I already have the files I need I just need the files so one of my friends can download it.

Share this post


Link to post
Share on other sites

A temporary solution for Blender users would be to export the model as 3ds or obj , and then import it in Zmodeler. Do some final touch ups, any bugfixes, center the axis, and scale the model down, then you can export it in Zmodeler as v3o.

  • Upvote 1

Share this post


Link to post
Share on other sites
On 2/25/2015 at 5:48 PM, MedicalByte said:

VFD for his patience while I bugged him with all my Zmodeler2 questions

So....

File's gone, and I'm screwed? 

Share this post


Link to post
Share on other sites

My apologies to everyone for the absence, especially to those of you who were relying on the scripts for your modeling.

I have re-attached the files to the original post, as well as uploaded the files to the download center (http://www.emergency-planet.com/files/file/1205-blender-v3o-importexport-scripts/).

 

Life has been busy (which is awesome!), thus the reason for my absence. I'll try to pay better attention to the thread should any issues arise in the future.

 

Y'all take care.

Share this post


Link to post
Share on other sites
On 2/15/2017 at 8:02 AM, itchboy said:

Some things I found regarding the v3o files in the materials line.

 

That is awesome! If I get any time I'll see about adding some options to the export script to allow for choosing the settings you want on export. I still remember scratching my head as to what some of those actually did haha.

Share this post


Link to post
Share on other sites

Hello there! Today it seems that I've completely finished my first model made completely from scratch! Though, there seems to be 2 problems. Note that these problems do not arise until after I convert the file to a .v3o file.

1. in order for the uv map to show up in-game, I have to manually type in the name of the .png file into the .v3o file after opening it up in notepad, I'm fine with this, but it doesn't allow me to input more than one file, and I need to use 2 textures.

2. the vehicle appears to be at a 90 degree angle to the right on the Y axis, though I didn't set it that way, and when I imported it and attempted to fix it, it would not save it that way.

Any help at all would be amazingly appreciated, I've been working on a model pack for you all and would love to release them, but these are the 2 issues getting in the way of that.

I can take some screen shots if needed too. Thanks.

Share this post


Link to post
Share on other sites

You need to make 2 materials. One for each texture you want to use.

In whatever software you're using, you need to re-align the axis so that it faces the correct direction.

Share this post


Link to post
Share on other sites

You cannot because the exporter splits all of the model's vertices.

You need to modify the exporter by removing the vertice split line from the code in order to smooth the model out.

Share this post


Link to post
Share on other sites


 

On 23.10.2018 at 4:51 AM, itchboy said:

You cannot because the exporter splits all of the model's vertices.

You need to modify the exporter by removing the vertice split line from the code in order to smooth the model out.

Do you happen to know which lines I need to remove? I wasn't succesfull so far...

Share this post


Link to post
Share on other sites

Did you also remove line 44? The split_edges line I mean.

If the model you're working on has the edges split, you will have to restore it manually by removing all the doubles and splitting the model section by section.

Share this post


Link to post
Share on other sites
20 hours ago, itchboy said:

Did you also remove line 44? The split_edges line I mean.

It's commented out with a '#'

20 hours ago, itchboy said:

If the model you're working on has the edges split, you will have to restore it manually by removing all the doubles and splitting the model section by section.

Makes sense to me. Removing doubles is no problem. I don't understand the second part thou.

Share this post


Link to post
Share on other sites
2 hours ago, Florian_S. said:

It's commented out with a '#'

Makes sense to me. Removing doubles is no problem. I don't understand the second part thou.

i use blender regularly and this is something i wasn't understanding until recently. So what you do is select each side(Left, Right, Front, Back, Top, Bottom, Etc) and press the Y key in the 3D view of blender. Upon doing this you will also need to select doors on buildings or anything that is uv'd seperatly(kinda like an object is being constructed seperatly in blender) and it will resolve the UV issues. Without splitting each side this is what the model will look like.

 

TNgaujJ.png

Building Model and Texture by - THVFD

Share this post


Link to post
Share on other sites

On my copy of Blender, the model goes into wireframe mode using the Z key.

If you're European, you might be using an AZERTY keyboard instead of QWERTY. Then the key for splitting the mesh might be different.

Share this post


Link to post
Share on other sites
11 hours ago, itchboy said:

Then the key for splitting the mesh might be different.

It's a QWERTZ layout so Y and Z are switched. Pressing Y calls split although it seems like nothing happens.

Share this post


Link to post
Share on other sites
5 hours ago, Florian_S. said:

It's a QWERTZ layout so Y and Z are switched. Pressing Y calls split although it seems like nothing happens.

it will seem like nothing happens it just sepereates the vertices that are connected to the other side there won't really be a noticable difference

Share this post


Link to post
Share on other sites

You should see the numbers on the upper right change once the mesh is split.

Btw, make sure that you remove the doubles on the entire model first.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×