Jump to content
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
leahcim512

Solution to crash to desktop (After 2 seconds black screen)

Recommended Posts

Hey Everyone, In my short time being on the forums I have noticed that in the technical support section has many people with the issue at start-up regardless the operating system.

Ive Started this topic mainly because the section has so many people with the same issue,
well the solution is simple.

You are required to have the most updated video card drivers for your system.
These can be gained from the manufacturers website the two main being:

http://www.nvidia.co...obal/global.php For Nvida Series graphic cards

AND

http://ati.amd.com/support/driver.HTML For ATI Model graphic cards

AND

http://downloadcente...om/Default.aspx For intel graphic cards // Download Center

If after reading this and your still having troubles feel free to post your DirectX Diagnostics File (dxdiag.txt)
This can be done by typing "dxdiag" into RUN Prompt.
After that select save and save the file to a location where you are able to find it.

Then attach it to a post on this section.

I hope this helps people, feel free to ask me any questions

 

PERSONS USING WINDOWS 7 & 8

 

Please note that you may still experience the crash to desktop even though you have the graphics card driver working, EM4/911 - First Responders does not like to work with the default Microsoft loaded device drivers that may have automatically installed or have been gained from Windows update services. You must still download from the above links to fix this problem!

//Updated Above Links

//Updated Windows 7/8 Details

Edited by leahcim512
Changed the title and pinned.

Share this post


Link to post
Share on other sites

Hey,

I still have the problem that when i start the game it goes black for 2,3 sec and than crashes to desktop.

Already have updated the videocard drivers with the correct ones.

here also mu DXDIAG

I run win 7 home 32 bit

Share this post


Link to post
Share on other sites
Guest shadowdrifter1

Hey,

I still have the problem that when i start the game it goes black for 2,3 sec and than crashes to desktop.

Already have updated the videocard drivers with the correct ones.

here also mu DXDIAG

I run win 7 home 32 bit

Same with me

Share this post


Link to post
Share on other sites
Guest shift944

Downloaded 911 First Responder, and at first everything worked fine, then maybe 5-6 minutes into the game the graphics all became exploded and the screen had that "shattered" effect. Then the game wouldn't even start, I get that black screen, then crash.

Downloaded 2010 Drivers for ATI Radeon X1 series Version 10.2, still nothing.

Attached is the DxDiag file.

Thank you in advance.

DxDiag.txt

Share this post


Link to post
Share on other sites

Downloaded 911 First Responder, and at first everything worked fine, then maybe 5-6 minutes into the game the graphics all became exploded and the screen had that "shattered" effect. Then the game wouldn't even start, I get that black screen, then crash.

Downloaded 2010 Drivers for ATI Radeon X1 series Version 10.2, still nothing.

Attached is the DxDiag file.

Thank you in advance.

DXDiag shows you installed a 2009 graphices driver...

But in order to see what is wrong we are gonna need a logfile. It's located in the main EM4 folder.

Share this post


Link to post
Share on other sites
Guest shift944

DXDiag shows you installed a 2009 graphices driver...

But in order to see what is wrong we are gonna need a logfile. It's located in the main EM4 folder.

Where is the EM4 folder? I don't have anything in Program Files for 911FR.

Under the display tab of DirectX Diagnostic the drivers are dated 2/11/10 Version 6.4.0010.6925 under Main Driver ati2vdag.dll. Not sure why the file says I still have 2009 drivers.

Share this post


Link to post
Share on other sites

Where is the EM4 folder? I don't have anything in Program Files for 911FR.

Under the display tab of DirectX Diagnostic the drivers are dated 2/11/10 Version 6.4.0010.6925 under Main Driver ati2vdag.dll. Not sure why the file says I still have 2009 drivers.

It is a sub-folder of Wizard Works.

Share this post


Link to post
Share on other sites

"?VulpineWrapper::ChangeScreenMode(): VERR_NOSCREENMODE - Screen mode could not be set"

You might try going into options and make sure the display settings are set to 800x600. The problem seems to lie some where with the graphics card.

Also get this driver:

http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_xp.aspx?type=2.4.1&product=2.4.1.3.13〈=English

This is from February 2010, so it is a newer driver then the one you have.

Share this post


Link to post
Share on other sites
Guest shift944

Tried changing to 800x600 in Display Properties, nothing. Cant change it in the in-game menu yet as game wont even start.

Downloaded the drivers again, and even after restarting it still refuses to work. The driver dates still say 2/11/2010 on the Diagnostic, they never updated. I'm out of ideas, and pretty disappointed in Atari right now, although maybe I just need a new graphics card.

I do appreciate the help guys, and hope something works sooner or later. Thank you.

EDIT: Downloading the the cfg file from here and replacing the one in the EM4 folder will help you get rid of the black start up screen problem. It doesn't prevent the graphics in the game from becoming all shattered though, but you might get a few extra minutes in before they do. Changing to 800x600 res didn't help this problem. The new log file is also there.

ReEDIT: Back to square one. Cant even start the game anymore. Tried replacing the cfg file but nothing. WTF

TripleEDIT: Went into Device Manager > Display Adapters and manually updated to Radeon X1300PRO Drivers. Game now starts up and runs just fine, but will crash after 15-20 min. ALMOST got it, YAY!

logfile.txt

Share this post


Link to post
Share on other sites
Guest Pilot_MKN

I'm having crash to desktop problems as well, but I'm working with the German demo of Emergency 4 ( I wanted to see if it would work on my laptop before I buy the game).

The opening cutscenes run then the screen flickers and I'm sent back to the desktop.

I'm running Windows 7 on a Dell laptop.

The steps I have taken so far are to lower my screen resolution (I've gone all the way down to 800X600 to no effect, I've updated my graphics drivers and I also downloaded the config files posted earlier to this top. None of these have changed anything.

I've attached my logfile below. Hopefully you can help.

logfile.txt

Share this post


Link to post
Share on other sites

The best way is by following the steps:-

1.If you have the game CD then it's great.If you do not have the CD then no point.

2.Insert the CD and click un-install.Don't worry you don't need to un-install the game.

3.Click repair and let it get repaired.This might take a few minutes.

4.Once done go to the em4.cfg file and open it with notepad.

5.Change s_language-fr to s_language-en.

6.Enjoy the game.

Share this post


Link to post
Share on other sites
1.If you have the game CD then it's great.If you do not have the CD then no point.

Not true. You should be able to just launch the installer exe and follow your instructions all the same.

Share this post


Link to post
Share on other sites

Did you read the first post? Did you try whats in the first post?

,

Yes. My driver is the latest, i´ve tried all the rest in previous post and still nothing ...

I dont know if is there some other requirement that i dont have....computers is not my thing :( :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...